Library compatibility

From GNUstepWiki

This is a basic list of version compatibility between the diffrerent GNUstep libraries and, perhaps, other programs that people would like to add.


Contents

GNUstep Make

No specific requirements

GNUstep Base

Version Requires
1.13.0 make >= 1.13.0 and < 2.0.0 (some incompatibilities)
1.14.X make >= 2.0.0
1.15.X make >= 2.0.0

GNUstep GUI

Version Requires
0.11.0 make >= 0.11.0 and < 2.0.0 (may be incompatible), base >= 0.11.0
0.12.0 make >= 2.0.0, base >= 0.14.0
0.13.0 make >= 2.0.0, base >= 0.15.1

GNUstep Back

Major and minor version must match Gui major and minor version.

GNUstep Applications

Application Version Requires
Gorm 1.2.2 gui >= 0.13.0