Talk:Installation on Windows

From GNUstepWiki

Revision as of 02:05, 28 February 2007; view current revision
←Older revision | Newer revision→

Are the *-bin.zip files needed? Are not the *-lib files sufficient?

Stefan Urbanek 16:06, 10 Mar 2005 (CET)

Installation quirks

I had to do:

configure CPPFLAGS=-I/C/GNUstep/msys/1.0/include LDFLAGS=-I/C/GNUstep/msys/1.0/lib

to get the gui build going.

Also, ffcall wouldn't compile, so it was necessary to copy one from an older GNUstep installation on windows. I will make a zip of this and put in on the GNUstep ftp site so that others don't run into the same issue.

Later, GJC

---

I don't think that the libiconv stuff is necessary anymore, at least not with modern source distributions of libxml2. Also, there should be a warning NOT to install libxslt, as it gets compiled as a static library and its symbols clobber *everything* inside a DLL (hence messing up gnustep-base). It needs to be fixed for mingw (I'm sure the authors would have if they ever used the configure script in MSYS).

TODO

OR

  • delete or convince everyone of putting these kind of things on the wiki and not in some external file.